Help and Tutorials

What versions of Lightroom are these effects compatible with?

Our Lightroom products are compatible with Adobe Lightroom CC 2015 (Version 6) and Lightroom Classic CC. RAW images are required for full functionality.

Note: The new cloud-based Lightroom CC is not officially supported and has limited functionality. You can apply an effect and position it, but Quick Color settings and any other features are not supported.

If you are not sure which version you have, simply open Lightroom, click File > About Adobe Photoshop Lightroom

Related questions:

Have more questions?

Open a ticket: help@lensdistortions.com