Help and Tutorials

What versions of Photoshop are these effects compatible with?

The Photo effects available on our website are compatible with Photoshop CS4 – CC.
(Not compatible with Photoshop Elements)
All languages are supported.

We do not offer any products for Adobe Lightroom at this time.

We also have a mobile photo app for iOS and Android. Requirements for the mobile app are available here.

Have more questions?

Open a ticket: help@lensdistortions.com